You are not logged in.


Sunday, April 29th 2018, 7:04pm

Blurry Graphics

Hi! First time posting here so i hope i'm posting in the right thread.
I've had issues for a while now, ever since i started playing, that the game is blurry. I maxed out all my settings, and i have sharpness at around 2.
If i increase sharpness it looks very weird so i just keep it at that. The downside is that everything seems blurry.
Like everything is melting together. So hard to explain, but i just came back to Allods from playing Legion in WoW so maybe it's just something i have to get used to.

Or is it some way to make it sharper around the edges? I see many youtubers videos with sharper edges than me (and i max everything in settings..)


Monday, April 30th 2018, 1:40am

its some kind of optical illusion and i already had some ppl asking me this regarding allods; i wondered about it myself too when i was new to this game...

for REALLY sharp edges set "sharpness" to "OFF" (slider to left; 1)
while on the 1st view it might look unsharp, actually it is perfectly sharp then

see this as an reference, the upper one is the real sharp one, it has only 2 colors
the lower part seems sharp but actually is just weirdly altered... contrast playes the eyes a trick... white + black have been mixed in as they are easier to seperate visually

more lecture about this:

some ppl dislike antialiasing, setting antialiasing to off also makes the image appear more "sharp" somehow, but its a subjective view - and some ppl dont like the pixelation-effect of a native resolution image... so best is you play around with it and see what is most plasent to your eyes

then there is SSAA which make the picture appear really blurry since its actually rendered at a higher res and then downscaled... but these things are set in the VGA driver and not in the games graphicsmenu anyway

This post has been edited 2 times, last edit by "ALLODS-ONLINE-PLAYER" (Apr 30th 2018, 1:51am)


Monday, April 30th 2018, 8:29am

Thanks for the detailed answer! I will try different settings then, and i'm glad i'm just not going crazy about the "sharpness" feature.


Monday, April 30th 2018, 8:36am

A quick update! I went in to radeon settings, and of course it was set to supersamlping. I turned it off and set it instead as multisampling(the only other option) and WOW what a difference! It feels like i got new glasses, lol. :D

Similar threads

Used tags

blurry, graphic

Rate this thread