You are not logged in.


Thursday, September 17th 2020, 2:27am

Interrupted Ritual fail w/ patch 11.1

With patch 11.1 the "Interrupted Ritual" quest in Umoir is automatically failing when the 3rd round of mobs shows up. I did this pre-patch with no problems. Tried it 4 times after the patch and kept agro on all the mobs. Catherina never got hit. Still failed. This is an important quest needed to advance.


Thursday, September 17th 2020, 5:37am

Same problem w/ Umoir quest "Clean thoughts, Clean hands" quest fails at 3rd round of mobs. I checked Velestav's health before the fail and he was at 100%.


Thursday, September 17th 2020, 11:19pm

Quest fail Update: I spent some time with these quests to figure out what was going on. It's the same problem with both. The mobs appear and instantly hit the NPC you are supposed to be protecting. The NPC dies in one shot and the quest fails. there is no time to get them to target you. I did manage to get a healer through both quests by constantly keeping a shield on the target and ignoring the mobs hitting me until the timer ran out. I ran this quest with a warrior just before the patch and had no problem. The NPCs took several hits before I could get aggro on them and they were fine. I think there will be classes that just cannot complete these quests unless the bug is fixed.


Friday, September 18th 2020, 10:52pm



Posts: 513

Location: Sweden

Occupation: Studying

  • Send private message

Send in a ticket , dont think it will be fixed by saying it on forums ;D ticket is fastest way hehe
I am PioPico

Rate this thread