You are not logged in.


Saturday, April 30th 2016, 9:39pm

Cant Get Back to Pearl ring

Hello, so recently i got to pearl ring with my was a bit higher level than the starting place of pearl ring but i got there, and at the start when the ship gets destroyed in the astral and you end up on the shore i did 1 quest and used my Adventurers stone to get to Yaskers tower,without opening a portal or anything to pearl ring. Didnt think that this problem would occur then so now i cant get to pearl ring. Tried automoving to the quests there. Tried automoving from the Recommended quest: New Adventures:Irdrich. It just leads me to the mailman. the Mailman does not give me anything that can help. Please help i dont know how to advance im stuck!


Saturday, April 30th 2016, 9:48pm


Go back the orc, in the basement of the Yasker Tower (opposite to Elisaveta), he should send you back to the ship.
Allods Online Discord
Check out the community chat
Rejoignez la communauté sur le serveur Discord Allods Online


Sunday, May 1st 2016, 5:16pm

He does not Give anything

EDIT: Reinstalled and the portal to Irdrich: Demon hunters ship appeared. Maybe it was there all along and i did not notice but i doubt it. anyways problem fixed

This post has been edited 1 times, last edit by "Warrior113" (May 1st 2016, 5:24pm)

Rate this thread