You are not logged in.


Sunday, January 17th 2016, 2:45am

Astral Academy - teleporter does not allow me go back (Lvl 8)

So im lvl8 and when i first arrived at Novograd i talked with the npcs at the docks.
Not so smart move talking to the Academy traveler who took me to the Academy docks

From there there is no teleport available as you can see. Before i went here though i checked the Stone/ruin in docks to be bound to.
But people who do not have NO availability to go back to Novograd :!: :?: so just waiting for CDR on my stone.

I tried CTRL+B but that only took me to servant of light in the same area behind the building. :thumbdown: :cursing:


Sunday, January 17th 2016, 3:51am



Posts: 1,349

Location: Wisconsin - USA

Occupation: Destoryer of all things you love

  • Send private message

LOLWUT That sounds horrible.
I have never heard of that before.
I am sorry :(


Sunday, January 17th 2016, 4:04am

i havent tested this, but...
in this case it might help to open up the map and select the portal in novograd (or some other that is reachable by foot) so your gibberlings automove to that location (automove takes paths that are not accessible through the interface sometimes)


Sunday, January 17th 2016, 9:12am

how can he ever leave the academy if he got no portal available even after the stone is off cd?


Sunday, January 17th 2016, 9:59am



Posts: 539

Location: Berlin

  • Send private message

mmhm, maybe:

return to academie by this guy inside the house?
teleportshard from cs?
jumping from allod and he respawns somewere else?
PLS make Tekians playable race. fix shipcanons!


Sunday, January 17th 2016, 11:59am



Posts: 530

Location: Kuopio, Finland

  • Send private message

This is actually a known issue and you need to contact support asap. It's because you haven't followed the right quest order which would have taken you to Novograd teleport and "bind there" first. You aren't supposed to visit Astral Academy before you get the quest open to meet an npc that allows you to summon mercenaries and in League side it's at level 11 when you get all Oreshek Fortress quests open for the first instance (dungeon).

But this isn't the only case with the same problem in League side. People like to explore and accidentally ends up teleporting themselves to Astral Academy before they've even visited Novograd. Then they are stuck. I can't recall was there any simple way out of there other than support.
New to Allods? Need few tips'n'tricks? Check ALLODS ONLINE SANCTUARY

Important guide for new players: Patronage: requirements and benefits


Sunday, January 17th 2016, 1:42pm

Support won't answer in reasonable time.

Better shout for help from other players. Many guilds have "Leader's Call" ruby that allows them to summon group members to their location. Group with such person and make them summon you to Novograd.


Sunday, January 17th 2016, 5:19pm

how can he ever leave the academy if he got no portal available even after the stone is off cd?
I just arrived at Novograd lvl 8 and talked with the flour/sack quest for rep then went to the stoneportal and binded to novograd docks.
And just after that i went straight into the Academy and he took me to the academy-docks

Some high lvl guild members invited me to guild and tried aswell. And tipped me about CTRL+B did not work and tried something else but just told me to login logout = no success and final step wait for CDR on the stone in bag.

But i found out "automove" on a quest in novograd which took me back :) :!:
So clearly needs some adjustment on that academy guy so beginners dont end up same as me.


Thursday, June 30th 2016, 9:22am

Yeah just select an quest in nova to auto move to it and you will leave the academy.


Wednesday, December 21st 2016, 11:49am

Yeah just select an quest in nova to auto move to it and you will leave the academy.

This bug exist in and this is the only one solution!!!

Similar threads

Rate this thread