You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, October 20th 2017, 7:32am

  • "xxtammyjayxx" started this thread

Posts: 42

Location: Australia

  • Send private message

Cursed Item Quest imp side

Hi when i got the cursed items quest on Empire side, I didnt get a purifying scroll to purify the belt you do for that quest. I had nothing to obatin a scroll or anything. All it gives me is a belt. nothing else. Ive abandoned the quest, and it still only gives me the cursed belt alone, ive tried disposing the belt and the quest and still the same thing. Ive also noticed other players have had that issue in the past and since ive been inactive for 2.5 yrs that problem still hasnt been fixed.
League side i can do that quest fine, i get the item to obtain the purifying scroll and use it.
Just my empire characters that dont seem to get the item.

Astral Nudists


Wednesday, November 1st 2017, 10:26pm



Worked fine for me. To be exact, it worked for me a total of 13 times.
Try checking again, you might just overlook something as with usual problems. Try to provide screenshots if possible so people helping you will have it easier to do so :)

Rate this thread