Vous n’êtes pas connecté.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

17. 09. 2020, 02:27

Interrupted Ritual fail w/ patch 11.1

With patch 11.1 the "Interrupted Ritual" quest in Umoir is automatically failing when the 3rd round of mobs shows up. I did this pre-patch with no problems. Tried it 4 times after the patch and kept agro on all the mobs. Catherina never got hit. Still failed. This is an important quest needed to advance.

2

17. 09. 2020, 05:37

Same problem w/ Umoir quest "Clean thoughts, Clean hands" quest fails at 3rd round of mobs. I checked Velestav's health before the fail and he was at 100%.

3

17. 09. 2020, 23:19

Quest fail Update: I spent some time with these quests to figure out what was going on. It's the same problem with both. The mobs appear and instantly hit the NPC you are supposed to be protecting. The NPC dies in one shot and the quest fails. there is no time to get them to target you. I did manage to get a healer through both quests by constantly keeping a shield on the target and ignoring the mobs hitting me until the timer ran out. I ran this quest with a warrior just before the patch and had no problem. The NPCs took several hits before I could get aggro on them and they were fine. I think there will be classes that just cannot complete these quests unless the bug is fixed.

4

18. 09. 2020, 22:52

Messages: 513

Localisation: Sweden

Travail: Studying

  • Envoyer un message privé

Send in a ticket , dont think it will be fixed by saying it on forums ;D ticket is fastest way hehe
I am PioPico

Noter cette discussion