You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, March 20th 2014, 1:34pm



still cant do anything

what exactly did you fix???i still cant do anything but lounch the game.i used ingame tool for transer.tried to login to site with old username,password,tried with email instead username,still getting that messige of unrecognised account or password thing.i tried to make entirely new account,once i logged out i get sam msg.i tied make another new account,and i get internal service what exactly did you fixed,lol.and what emails exactly going to send info about resolving those things.the one i cant even register with on here???oh and i dont have that gpotato-wbzen error thingy becouse there is NOT ANY LINK FOR TRANSFERING ON THEIRE SITE

Rate this thread