You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Saturday, March 22nd 2014, 1:11am

GuessItsAmber

Intermediate

  • "GuessItsAmber" started this thread

Posts: 447

Location: In my little corner of YT so stay out of it.

Occupation: Pro Afk'r

  • Send private message

Hi,

Is this problem ever gonna get addressed or am I just gonna have to uninstall the game for good?
http://i57.tinypic.com/wla91l.jpg

A friend of mine was stuck @65% yesterday, i told him to stop the game, disconnect from the MyGames launcher too, and reboot its computer.
Then launch the game with Allods Launcher (in your My.Games\Allods Online\bin folder, find "launcher.exe") and he finished downloading with this solution.

I don't know if it can help you too.

Good luck :/.
Thank you for the suggestion all it did was get me into the game still not downloading.

22

Saturday, March 22nd 2014, 1:16am

Hello,

Thank you for the suggestion all it did was get me into the game still not downloading.

Oh ok :(.
Do you have any firewall on your computer that may block the connexion ?
There may be some settings to do, but at the moment i don't know which one. Maybe someone will find the solution.
Try to launch Allods, or my.games launcher, with Administrator mode ?

No more ideas, sorry,

Good luck.
Allods Online Discord
Check out the community chat
----
Rejoignez la communauté sur le serveur Discord Allods Online

23

Saturday, March 22nd 2014, 1:38am

Leave it overnight and come back then stop the download and restart it and should be done that what happened to me :)
Drakeos - Empire Engineer

Rate this thread