You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Sunday, March 23rd 2014, 8:29pm

Game broken

Hi to everyone i have a problem that i opne the game and then sends me a message saying:
Internal error (error code: 0xE2003059). Close all applications and try again.
If this does not help, press "Error report" and send the report to product customer support.

I use the repair tool but its still not working i searched in google but all the problems are in the old allods forums so.. if anyone can help ill grateful.


Sunday, March 23rd 2014, 10:58pm



I've got the same problem , I tried so many things but nothing worked.


Sunday, March 23rd 2014, 11:17pm



I just solve the problem , I hope it will works for you.

Check if you have BrowserProtect / BrowserManager installed on your computer.And / or if a service with that name is running.Just remove it and Allods will not crash anymore.Because of Allods Online using Awesomium , the adware "BrowserProtect" is trying to hack something in the game and it's crashing


Monday, March 24th 2014, 9:34pm



Game freeze and I get disconnected


I've got a similar problem.

When I am in Nezeb (Yasker tower) the game freezes after a few seconds and I get disconnected.
When I log in again the same thing happens.
If I manage to get outside Yasker tower the game works alright.

Can anyone help or advise?


Rate this thread