You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, March 27th 2014, 4:52pm


I know that there already is a thread about the same subject, but I've just tried to top-up my account. After entering the CC number and CVV and clicking "Complete Payment" I get no response. The three little dots start dancing and then it resets back to a empty CC entry form. Anyone got any info on why that might be happening.

Using Credit Card Euro payment option. There are enough funds in the account. I've used the same CC before.


Thursday, March 27th 2014, 4:58pm



Posts: 619

Location: UK

Occupation: Enterprise Grade IT Support

  • Send private message

The billing portal is still under construction and may not accept all payment types - do you have a system like Verified by Visa on your account?
Have you tried turning it off and on again?


Thursday, March 27th 2014, 5:00pm

Erm no... I think. How does one go about procuring something like that?

Also how does that help me in any shape or form?


Thursday, March 27th 2014, 5:46pm



Posts: 5

Occupation: Healthcare

  • Send private message

Yup mine is doing the same ;(

<60 Paladin>


Thursday, March 27th 2014, 7:21pm

Did you manage to top-up under management at all? Or is this the first time you've tried using it?

I'd recon something like this warrants a response. It's all nice that they rolled out a cash shop event...that we cant even use. Does that make any sort of sense to anyone?


Thursday, March 27th 2014, 7:24pm

I am having the same problem. I am using US CC and no luck either. I have sent 2 help tickets also. I am getting no help


Thursday, March 27th 2014, 7:26pm

Oh and my bank notified me and asked me to authorize this purchase.. So I did yesterday morning. Still nothing today :((


Thursday, March 27th 2014, 7:32pm

Might be worthwhile trying to contact your bank and check on the status of the purchase? Could be the site/merchant/provider/gateway payment needs to be white-listed or something? Or is it still not fully running? Or both. A official response would be much appreciated. Has anyone had any luck topping up?


Thursday, March 27th 2014, 7:33pm



Posts: 619

Location: UK

Occupation: Enterprise Grade IT Support

  • Send private message

Erm no... I think. How does one go about procuring something like that?

Also how does that help me in any shape or form?

It doesn't - but it can cause issues with billing systems.

If you dont have it, it's not to blame!
Have you tried turning it off and on again?


Friday, March 28th 2014, 7:32am

So, any update? Has anyone had any luck topping up under management? Is anyone in charge even aware of this problem? And if so, is there an ETA on a fix? Or at least an explanation of whats wrong?


Friday, March 28th 2014, 8:51am



Posts: 73

Location: Danmark

  • Send private message

I completed my first top op after the patching yesterday. It worked just fine. My topup was a paypal Euro thing.

It might not be that, but try checking your setup for opening of new windows - the authorization process for me opened in a new window. Im thinking, some might have blocked pop ups.
Araanahn - Kanian Crusader - Warsong guild


Friday, March 28th 2014, 11:10am

Just to be sure I enabled all site pop ups, even though I was sure this was not the case, had a pop up been blocked Chrome would've displayed that little Pop-up blocked thingy.

Tried with pop ups enabled, still not working. The only thing that comes to mind is that paypal method is working and CCs do not.

I'm not touching paypal with a bloody ten foot pole. Oh well, guess we'll just have to wait.


Friday, March 28th 2014, 11:31am

or me when i topup with $10,- above it does not work either, but when i pay $10,- exactly it does work. you should try that


Friday, March 28th 2014, 11:35am

Erm, not sure if I got what you are saying. Paypal works for you? But Credit Card doesn't?

If that is the case, I wont be topping up at all or at least until it's fixed. Not touching Paypal.


Friday, March 28th 2014, 11:41am

I use a e-voucher, its an temporary creditcard bought on the internet.
I have 20 dollars on it but when i try to pay 20 dollar to i get the same problem as u.
BUT when i pay $10,- exactly then i can make the payment.

Thought that might work for u, at work now and prob had some lag so the whole message did not show up.


Friday, March 28th 2014, 12:07pm

That's a bit odd. That just raises further questions.


Friday, March 28th 2014, 12:09pm

ye it does but it currently works for me, let me know if it works for you to so we can maybe ad a thread about it so people can start topping-up again.


Friday, March 28th 2014, 3:53pm

try a lower amount, the system isn't working properly when i try to upload 100€ it fails and tells me to contact ticket service but when i tried 50€ it worked, so you might wanna try a lower amount, maybe it works for you aswell


Saturday, March 29th 2014, 6:46pm

PLEASE FIX THE BILLING SYSTEM for us to use Credit Cards USD !

Likewise will not touch PayPal, we should be able to use internationally accepted Credit Cards fgs !



Sunday, March 30th 2014, 7:07am

paid for 120 dollars of coins and no coins

i have bought 120 dollars worth of coins and i didnt get a single one via pay pal i bougth them in 60's twice pls fix it

Rate this thread